Release

27 posts

libssh 0.8.4 and 0.7.6 security and bugfix release

This is an important security and maintenance release in order to address CVE-2018-10933.

libssh versions 0.6 and above have an authentication bypass vulnerability in the server code. By presenting the server an SSH2_MSG_USERAUTH_SUCCESS message in place of the SSH2_MSG_USERAUTH_REQUEST message which the server would expect to initiate authentication, the attacker could successfully authentciate without any credentials.

The bug was discovered by Peter Winter-Smith of NCC Group.

Advisories and Download

Advisories and patches for older versions can be found here.

If you are new to libssh read The Tutorial how to get started. Please join our mailing list or visit our IRC channel if you have questions.

You can download libssh 0.8.4 or 0.7.6 here.

ChangeLog 0.8.4

  • Fixed CVE-2018-10933
  • Fixed building without globbing support
  • Fixed possible memory leaks
  • Avoid SIGPIPE on sockets

ChangeLog 0.7.6

  • Fixed CVE-2018-10933
  • Added support for OpenSSL 1.1
  • Added SHA256 support for ssh_get_publickey_hash()
  • Fixed config parsing
  • Fixed random memory corruption when importing pubkeys